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Abstract. The ANDVisio tool is designed to reconstruct and analyze associative gene networks in the earlier developed Asso-
ciative Network Discovery System (ANDSystem) software package. The ANDSystem incorporates utilities for automated
extraction of knowledge from Pubmed published scientific texts, analysis of factographic databases, also the ANDCell database
containing information on molecular-genetic events retrieved from texts and databases. ANDVisio is a new user’s interface to
the ANDCell database stored in a remote server. ANDVisio provides graphic visualization, editing, search, also saving of asso-
ciative gene networks in different formats resulting from user’s request. The associative gene networks describe semantic rela-
tionships between molecular-genetic objects (proteins, genes, metabolites and others), biological processes, and diseases.
ANDVisio is provided with various tools to support filtering by object types, relationships between objects and information
sources; graph layout; search of the shortest pathway; cycles in graphs.
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1. Introduction

The number of publications in the areas of biology,
medicine, and biotechnology increases with an alarming
rate that makes imperative computer-based analysis. To
date, over 20 million abstracts highly relevant to biology
and medicine are stored in the PubMed database and the
number keeps increasing.
To address the confounding problem of extraction of

information on molecular-genetic objects from texts
worldwide, approaches based on algorithms, from the
simplest, such as search for co-occurrence of the biolo-
gical object names in texts, to complex integrating
linguistic-semantic analysis, and machine learning have
been suggested and recognized.

The PubGene is an example of a co-occurrence based
system for reconstruction of networks for relationships
between proteins, genes, biological processes [9].
Cooper et al. [5] have developed a system for prediction
of protein-protein interactions. For this purpose, they
utilized a text analyzer that relied on the combination
of linguistic and statistical rules. GeneScene [15] and
MedScan [17] implement algorithms derived from lin-
guistic insights: full-sentence parsing, syntactic and
semantic analysis. This strategy was applied by Timur
Fayruzov et al. [7] to resolve the issue of extraction of
information on relationships between proteins.

There are thousands of factographic medicobiologic
databases, storing compiled information on biological
objects and their interactions. These databases are
extremely bulky, the NCBI Gene database [16] alone
contains over 7 million entries and this number keeps
growing. Thousands of facts regarding biomedically
and biotechnologically significant gene networks,
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metabolic and signaling pathways are deposited in the
KEGG [10], EcoCyc [11], GeneNet [2] and other
databases.
We benefited from previous work that made available

the ANDSystem [6] designed to automatically extract
information on molecular-genetic events in the cell from
Pubmed texts and factographic databases. This informa-
tion is continually accumulating in the knowledge base
ANDCell, which is part of ANDSystem.
There are various program products to resolve the

problem of visualization and analysis of biological
networks. Cytoscape [20], Ondex [14], VisAnt [21],
Vanted [3] are notable products. Most programs are
implemented in Java. This imposes certain limitations
on the size of the analyzed networks. Their other dis-
advantage is the lack of specialized tools for analysis
of bipartite graphs.
The ANDVisio tool presented here is a new module

of the ANDSystem. ANDVisio provides a graphical
interface for easy access to ANDCell, and allows to
reconstruct and analyze the associative gene networks
comprising relationships between molecular-genetic
objects (genes, proteins, metabolites), biological pro-
cesses, and diseases.
The ANDvisio program is written in Pascal. The

program does not require a large amount of RAM.
The program allows you to work with large bipartite
graphs with directed and undirected edges. A bipartite
representation allows viewing of a network in which
more than 2 objects are involved in one interaction.
The program implements algorithms for search of the
shortest pathways and cycles with network specific
features taken into account.

2. Main modules of the ANDSystem

The ANDSystem incorporates tools for automated
extraction of knowledge on molecular-genetic events
from Pubmed texts and factographic databases that
are stored in the ANDCell knowledge base [6]. The
following object types are considered: proteins, genes,
metabolites, microRNA, diseases, biological processes
and cellular components.
The following relationships types between objects

are considered.
Association type is used to define the relationships

between genes and diseases. The Association is also used
as a type of relationships between other objects, if a par-
ticular type of relationship has been omitted in the text.

Interactions, formation of molecular complexes
(protein-protein, protein-metabolite, protein-cellular
component and others).

Co-expression, simultaneous expression of several
genes due to common regulator mechanisms activat-
ing gene expression under the effect of changing
intracellular conditions.

Treatment, use of a molecular agent for treatment
of known disease. Proteins and metabolites (drugs)
can be involved in interactions of this type.

Catalytic reactions are those involving metabolites
as substrates and products, also a protein as an enzyme
catalyzing this reaction.

Conversion of molecules. This type is assigned a
reaction in the case when a catalyst enzyme is not indi-
cated, alsowhen the reaction proceedswithout a catalyst;
metabolites are involved in the conversion. Interaction
of the initial and the final products of a metabolic path-
way consisting of a number of intermediate steps are
referred to conversion.

Degradation of a protein (substrate) by another
protein (proteolytic enzyme).

Regulation of gene expression by transcription fac-
tors, also by their ligands. This category includes both
direct regulatory events, i.e. regulation of gene expres-
sion by a transcription factor that physically interacts
with gene promoter, and indirect regulatory effect of
their ligands, also proteins along the regulatory path-
way, including receptor and proteins of the signaling
pathway.

Regulation of activity or function of protein, gene cel-
lular component or molecular-genetic process. Protein,
metabolite, cellular component can serve as regulators.

Regulation of transport proteins or metabolites
between cell compartments as well as the secretion of
these molecules from the cell. Proteins, low-molecular
substances or cellular components can serve as regula-
tors of transport.

Regulation of stability or degradation of mole-
cular objects. Molecular structure of protein, mRNA
transcribed from genes, cellular components, and
molecular-biological processes can be objects of this
regulation.

Regulation of molecular-biological processes and
diseases. Proteins, metabolites, cellular components,
and molecular-biological processes can serve as regu-
lators like in the above cases.

Furthermore, regulatory events are subdivided accord-
ing to the effect one object has on another, i.e., activating
or inhibiting of the process.
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Algorithms for extraction of knowledge from text
implemented in ANDSystem use dictionaries, syntactic
and semantic rules (templates) [6]. Thesauri for object
names were compiled using available databases. A dic-
tionary of proteins was compiled from the Swissprot
database; genes from NCBI Gene; metabolites from
ChEBI; diseases from PharmGKB; microRNA from
MirBase; biological processes and cellular components
from Gene Ontology. About 4000 templates for extrac-
tion of knowledge on object relationships from texts
were used. The ANDCell knowledge base now stores
more than 5 million facts concerning relationships
between molecular-genetic objects, diseases and biolo-
gical processes.
The new ANDVisio module is a client’s appli-

cation with graphical user’s interface implementing
interaction with the ANDCell database. Application
allows the user to perform queries to ANDCell and
obtain interactive graphical networks. Networks can

be analyzed by built-in tools. Networks can also be
saved as a file in different formats.

3. The ANDVisio interface

The main window has the main menu, two panels
with buttons for quick access to common functions,
an area for display of networks as a list of all partici-
pants of the network with their properties, an area for
graphic visualization of the network (Fig. 1).

The “File” menu contains the “Connect” item. The
“Connect” item allows to recover the connection with
ANDCell. In the event that it cannot be recovered, a
warning message appears and all functions for further
work with ANDCell are blocked.

Making queries to the associative gene networks
“Query wizard” item opens a form for setting query
parameters to ANDCell (Fig. 2). Form is comprised

Fig. 1. ANDVisio main window. Network of the first level for protein PPARG (Cricetulus griseus) is given. The main window consist of three
parts: main menu panel with buttons for quick access to common functions, an area for display of networks as a list of all participants of the
network with their properties, an area for graphic visualization of the network.
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of a number of tabs referred to two groups. The first
group contains the “Synonyms” and the “Database
links” tabs. These tabs are responsible for input of
objects of interest. The other tabs are of the second
group and are responsible for setting of filters for the
resulting network.
On the “Synonyms” tab, the user can input the pat-

tern of object name and choose object type (Fig. 2).
Clicking the “Add” button will search objects in the
database that match with the name indicated by the pat-
tern. If more than one object search conditions is
found, the form for specifying objects of interest
appears (Fig. 3). The form is divided into 2 parts, the
accessible objects satisfying the above criterion appear
on the left, the list of chosen objects appears on the
right panel. For convenience of user’s choice of objects
of interest, all names and organism references are given
for each object. There are two ways to move objects
from one panel to another: either by the Drag&Drop
mechanism or by clicking buttons in the middle of
the form. The button functions are “>>>” and “<<<”,
they make possible movement of all objects from one
panel to another, but “>” and “<” move all the selected
objects. After confirmation of the list, the chosen
objects are included in the list of “Query wizard”.
On the “Database links” tab, the user can indicate

objects of interest using their identifiers in external

databases (Fig. 4). Identifiers can be added to the list
either one at a time or several simultaneously. To add
one identifier, it should be input into the “Database
ID” field. To input several identifiers at a time, they
should be saved as text file (each identifier should be
written in a separate line), then the created file should
be selected in the “Filename” field. The next step is indi-
cation of the database name whose identifiers are given.
If the database name is unknown, one can try to find
these identifiers across all available databases, but a lot
of database identifiers intersect and correspond to com-
pletely different objects. After clicking the “Add” but-
ton, identifiers are added to the list of objects.

Network level means here the maximum length of
the shortest pathway from the initial vertex to all other
vertices. Network level can be added before the addi-
tion of new objects to the list and after it. Network level
can be given individually for each object in the list.

The “Direct relations only” item can be checked
when directly linked objects are required and the
objects at level 1 do not have to be interrelated.

The “Organism” tab allows the user to submit the list
of organisms of interest (Fig. 5). At the bottom of the
“Organism” tab, the pattern of the organism name is
entered; this is followed by clicking the “Add” button.
If more than 1 organism meeting requirements is found,
a form to specify organisms of interest will open.

Fig. 2. “Query wizard” window. The “Synonym” tab. The name “pparg” is introduced into the “Synonym” field.
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Fig. 3. Object selector window. The list of found objects is on the left. The list of chosen objects is on the right. The list of synonyms and
corresponding organism name can be visualized for each object.

Fig. 4. “Query wizard” window. The “Database links” tab. The identifier of protein “O54312” from the Swissprot database is introduced into the
“DatabaseID” field. Pressing the “Add” button will add it to the protein list with the “P12345” identifier.

P.S. Demenkov et al. / ANDVisio: a new tool for graphic visualization and analysis of literature 153



The “Database filter” tab allows to choose the data-
bases from which relationships between objects will
be selected (Fig. 6).
The “Object filter” tab indicates the object types

necessarily presented in the reconstructed network
(Fig. 7).
The “Interaction type filter” tab indicates the rela-

tionships necessarily presented in the reconstructed
network (Fig. 8).
After filling in the “Query wizard” form, the “OK”

button must be clicked; it submits the query to
ANDCell. The result of the performed query is shown
at the Fig. 1.
All the objects grouped by types of the associative

network will appear as a tree in the left window. A list
of synonyms of its names and organism is provided
for each object. Double clicking the object selects it
and arranges the network in a way to place the object
in the center of the window. Double clicking the
object in the network performs a search of the list in
the left panel grouped according to types.
Relationships in the left panel are grouped according

to types. All the participants and their properties are
given for each relationship. Clicking mouse left button
on the object selects it by highlighting in red.

Unchecking in the “View->Show connections” menu
item will disable highlighting.

The “View->Show names” menu item controls dis-
play of object names.

The fit of the network to the window is achieved by
clicking the “View->Fit in screen” menu item.

The right click of mouse button opens the context
menu. To obtain more detailed information on the
properties of this object, the “Property” item can be
chosen from the context menu.

Synonyms of the object are given in the top panel
of the window of the object properties, the references
to its identifiers in the different databases are given in
the bottom panel (Fig. 9). Clicking references pro-
vides access through the web-browser to the object’s
entry in the chosen database.

In the top field of the window, interaction properties,
type of the interaction and its participants (name, object
types, role of objects in the interaction) are indicated
(Fig. 10).

In the bottom field, the interactive references to the
database, the source of information on the interaction
are indicated.

If the information on the interaction is retrieved from
Pubmed abstracts using text-mining, the sentence from

Fig. 5. “Query wizard” window. The “Organism” tab. “Human” is introduced into the “Organism” field. Pressing the “Add” button will add it to
the list of “Cricetulus griseus” organism.
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Fig. 6. “Query wizard” window. The “Database filter” tab. The user is suggested to choose the databases in which relationships will be searched.

Fig. 7. “Query wizard” window. The “Object filter” tab. The user is suggested to choose the object type which will be represented in the built
network.
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which information on interaction, all the references
containing it will appear.

3.1. Graph layout

A graph layout is performed automatically on a plane
for the easiest visualization of networks. To re-layout
after moving the objects, choose the “Layout->Relayout
graph” menu item.
Layouts of two types are available. Fast layout

“Layout->Select layout type->Fast layout” is designed
to draft huge networks. The designation of slow
layouts “Layout->Select layout type->Slow layout” is
a more thorough layout of small networks.
The layout algorithms are based on force-directed

layout algorithm [8]. In the layout algorithms, a graph
is considered as a set of physically interacting objects.
Graph modification precedes in the “Fast layout”.
All vertices with “Relationship” type are removed. As
a result, the graph becomes monopartite. Virtually all
of the vertices are connected to each other by springs
with different stiffness. The algorithm searches the state
of minimal system energy. At the end of algorithm

work, the removed vertices are restored and placed
in the center between interconnected vertices (the
“Straight relations” procedure is performed). In the
“Slow layout” algorithm, all the vertices of the graph
are considered as charged particles with different
charges. The algorithm searches the state of minimum
energy system. This version of algorithm uses informa-
tion on all vertices thereby allowing to improve quality
of layout. However, it requires greater computational
costs.

To change the layout of a network fragment, select
the objects within it, then click the “Layout->Layout
selected” menu item. Clicking the “Layout->Straight
relations” menu item will rearrange the interactions
without changing the position of the objects. As a
result, the interactions will be placed between the
involved objects.

3.2. Search of objects in a network

To find an object in a network by its synonym, sub-
mit it to the “Search” field (Fig. 1). The result is
brought up as a list on the “Search” tab in the left

Fig. 8. “Query wizard” window. The “Interaction type filter” tab. Only the interaction types that user indicates in this tab will be searched in the
ANDCell database.
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window. To return to the complete list of all partici-
pants of the network with their properties, click the
“All graph” tab in the left window. It is admissible
to enter name patterns into the search field using sub-
stitution characters * (any number of any characters)
or ? (any character).

3.3. Network editing

To remove an object (a group of objects), either
select it and choose the “Edit->Hide selected” menu
item or press Del.
To use a filter in a reconstructed network, choose

the “Edit->Filter” menu item. Choose filter properties
as described above for “Query wizard”.

To add an object to the reconstructed network, choose
the “Edit->Add objects” menu item. Choose the objects
and indicate filter properties, as described above for
“Query wizard”.

Check the “Don’t connect with existed objects”
item to make redundant mention of relationships bet-
ween the added objects and those present earlier in
the network.

To expand the network by adding new objects related
to one or more objects from the reconstructed network,
select these objects and choose the “Expand” context
menu item. Indicate filter properties, as described above
for “Query wizard”. Check the “Don’t connect with
existed objects” item, so as not to show the relationships
between the objects added to the network and those that
have been submitted to it.

Fig. 9. Object property form. Information on organism, list of synonyms and list of object identifiers are given.
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3.4. Analysis of associative networks

ANDVisio allows to search for close cycles and the
shortest pathways between two objects in an associative
network. In the search of the shortest pathway, select two
objects (select one object and holding down Shift, select
the other). Choose the “Analysis->Find the shortest
pathways” menu item. The list of the found pathways
will appear on the “Pathways” tab in the left panel
(Fig. 11). To view the participants of the pathway, click
“+” next to the pathway name. To highlight in color or
bold the pathway, click mouse right button on pathway
name and choose the “Highlight” item from the context
menu. Choose line type and color for highlighting

pathway. To use this option, it is advised to disable
highlighting of the selected object by unchecking the
“View->Show connections” menu item. To search for
minimum cycles comprising an object, select it and
choose the “Analysis->Find cycles” menu item. The list
of the found cycles will appear on the “Cycles” tab in the
left panel. To view the participants of the cycle, click “+”
next to the cycle name. The cycle can be highlighted in
the same way as the pathway. A search of a set of funda-
mental cycles is feasible. The “Analysis->Find funda-
mental cycles” menu item serves for this purpose.
A list of cycles will appear on the “Cycles” tab on the left
panel. The cycles can be highlighted in the same way as
the pathway.

Fig. 10. Interaction property form. Information on interaction type, list of participants, proposals with indication of the relationship and
identifiers of databases in which this relation is described are given.
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3.5. Saving networks

To save a built network, choose the “File->Save
as …” menu item. Saving can be in three formats:
XML (ANDVisio) (by default), AND Native, XML
(GeneNet).
The XML (ANDVisio) format allows saving all the

data regarding a network, the saved network can be
opened. The format is insensitive to changes in the list
of the vertex and edge attributes. File size can be quite
large. As a consequence, RAM should be large to accom-
modate the file. It is safe to save up to 10000 vertices.
Saving of network containing 10000 vertices can take
up to 5 minutes, depending on a computer power.

An extensive network can be saved in the binary
AND Native format. Files with networks saved in this
format occupy much less space on a disc, as compared
with the XML format. Saving and opening are fast,
ever for networks containing over 200000 vertices.
Runtime is somewhat more than 1 minute.

The XML (GeneNet) format is designed to export
networks in the GeneNet format [2]. Some applications
for graph analysis, simulation of the dynamics, among
others have been developed at the Institute of Cytology
and Genetics SB RAS. Their common feature is the
ability to open files in the GeneNet format.

To save a reconstructed network as an image,
choose the “File->Save as image …” menu item.

Fig. 11. Search results for shortest pathways between open angle glaucoma and myopia. In the left panel is a list of pathways. For each pathway
is a list of participants. Pathway number 13 is in bold dashed line.
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The network can be saved in the BMP, PNG or JPG
formats.
To open a network, previously saved either in the

AND Native or XML (ANDVisio) formats, choose the
“File -> Open …” menu item. Files can be opened and
work with the saved networks can be done regardless of
whether or not there is connection with the ANDCell
database.

4. Search of possible pathways for relation between
myopia and open angle glaucoma

UsingANDVisio, we have previously built an associa-
tive network for relationship between human genes and
proteins that are associated with open angle glaucoma
on the one hand and myopia on the other [18]. The net-
work, which we built, contains 50 proteins and 15 genes
associated both open angle glaucoma andmyopia as well
as more than 400 relationships between them (Fig. 12).
Using a tool to find the shortest pathways in the network
can be identified 26 pathways between myopia and open
angle glaucoma, which contains the most important
objects and relationships (Fig. 11). Two of them are
described in [18]. These include proteins PAX6, NOE3,

MYOC, SMAD3, IPO13, GCR and the gene OLFM3.
Other pathways that have been discovered, require addi-
tional analysis.

5. Conclusion

The created ANDVisio application provides graphi-
cal visualization, editing, search, saving of networks
reconstructed on request to the ANDCell database.
The reconstructed networks describe semantic relation-
ships between molecular-genetic objects (protein, gene,
metabolite, microRNA), biological processes, and dis-
eases. The program provides the user with universal
tools for network analysis. These include filters by types
of objects and their relationships; graph layout; search
for the shortest pathways; cycles in graphs. ANDVisio,
which is incorporated into ANDSystem, can be helpful
in resolving a number of issues in various research
areas: systems biology, biomedicine, biotechnology for
the reconstruction and analysis of associative gene net-
works. The complexity and diversity of information
scattered in the different databases are ever harder to
capture and stir interest in computable resources for
knowledge discovery.

Fig. 12. The associative network for relationship between human genes and proteins that are associated with open angle glaucoma and myopia.
Proteins PAX6, NOE3, MYOC, SMAD3, IPO13, GCR and the gene OLFM3 are marked by large icons.
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